# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)_t_p(\d+).html/$1\/page\/$2/gm;t' <<< "http://www.example.com/movile/this-is-a-tag_t_p7.html
http://www.example.com/other-is-a-tag_t_p7.html
https://www.example.com/_to?link(test_t_)ishelp9.hml
"