import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)_t_p(\\d+).html";
final String string = "http://www.example.com/movile/this-is-a-tag_t_p7.html\n"
+ "http://www.example.com/other-is-a-tag_t_p7.html\n"
+ "https://www.example.com/_to?link(test_t_)ishelp9.hml\n\n\n";
final String subst = "$1/page/$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}