$re = '/(.*)_t_p(\d+).html/m';
$str = 'http://www.example.com/movile/this-is-a-tag_t_p7.html
http://www.example.com/other-is-a-tag_t_p7.html
https://www.example.com/_to?link(test_t_)ishelp9.hml
';
$subst = "$1/page/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;