import re
regex = re.compile(r"(.*)_t_p(\d+).html", flags=re.MULTILINE)
test_str = ("http://www.example.com/movile/this-is-a-tag_t_p7.html\n"
"http://www.example.com/other-is-a-tag_t_p7.html\n"
"https://www.example.com/_to?link(test_t_)ishelp9.hml\n\n\n")
subst = "$1/page/$2"
result = regex.sub(subst, test_str)
if result:
print(result)