const regex = /(.*)_t_p(\d+).html/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)_t_p(\\d+).html', 'gm')
const str = `http://www.example.com/movile/this-is-a-tag_t_p7.html
http://www.example.com/other-is-a-tag_t_p7.html
https://www.example.com/_to?link(test_t_)ishelp9.hml
`;
const subst = `$1/page/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);