using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(http:\/\/)?(www\.)?\w+\.\w{1,3}$";
string input = @"http://www.example.com
http://example.com
www.example.com
example.com
www.example
http://www.example";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}