$re = '/^(http:\/\/)?(www\.)?\w+\.\w{1,3}$/m';
$str = 'http://www.example.com
http://example.com
www.example.com
example.com
www.example
http://www.example';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);