re = /^(http:\/\/)?(www\.)?\w+\.\w{1,3}$/m
str = 'http://www.example.com
http://example.com
www.example.com
example.com
www.example
http://www.example'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end