package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(http:\/\/)?(www\.)?\w+\.\w{1,3}$`)
var str = `http://www.example.com
http://example.com
www.example.com
example.com
www.example
http://www.example`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}