// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(http:\/\/)?(www\.)?\w+\.\w{1,3}$").unwrap();
let string = "http://www.example.com
http://example.com
www.example.com
example.com
www.example
http://www.example";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}