# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^][(){}]//g;t' <<< "(9*[3*{[(3+3)/5]*7}])"