use strict;
my $str = '(9*[3*{[(3+3)/5]*7}])';
my $regex = qr/[^][(){}]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";