using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^][(){}]";
string substitution = @"";
string input = @"(9*[3*{[(3+3)/5]*7}])";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}