$re = '/udp\s+.\d+\s+\d+\s+(?!127.0.0.1)\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}:514\s+0\.0\.0\.0:\*\s+(\d+)\/syslog-ng/';
$str = 'udp 0 0 0.0.0.0:514 0.0.0.0:* 2103/syslog-ng
udp 0 0 127.0.0.1:514 0.0.0.0:* 2103/syslog-ng
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);