re = /udp\s+.\d+\s+\d+\s+(?!127.0.0.1)\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}:514\s+0\.0\.0\.0:\*\s+(\d+)\/syslog-ng/
str = 'udp 0 0 0.0.0.0:514 0.0.0.0:* 2103/syslog-ng
udp 0 0 127.0.0.1:514 0.0.0.0:* 2103/syslog-ng
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end