import re
regex = re.compile(r"udp\s+.\d+\s+\d+\s+(?!127.0.0.1)\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3}:514\s+0\.0\.0\.0:\*\s+(\d+)\/syslog-ng")
test_str = ("udp 0 0 0.0.0.0:514 0.0.0.0:* 2103/syslog-ng\n"
"udp 0 0 127.0.0.1:514 0.0.0.0:* 2103/syslog-ng\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")