#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[-]{1}[1]{0,1}\s*cot\s*[\(]*\s*x\s*[\)]*\s*\+\s*[a-z]{1}\s*"
Local $sString = "-cot(x) + c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")