const regex = /[-]{1}[1]{0,1}\s*cot\s*[\(]*\s*x\s*[\)]*\s*\+\s*[a-z]{1}\s*/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[-]{1}[1]{0,1}\\s*cot\\s*[\\(]*\\s*x\\s*[\\)]*\\s*\\+\\s*[a-z]{1}\\s*', 'm')
const str = `-cot(x) + c`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}