re = /[-]{1}[1]{0,1}\s*cot\s*[\(]*\s*x\s*[\)]*\s*\+\s*[a-z]{1}\s*/m
str = '-cot(x) + c'
# Print the match result
str.match(re) do |match|
puts match.to_s
end