package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-]{1}[1]{0,1}\s*cot\s*[\(]*\s*x\s*[\)]*\s*\+\s*[a-z]{1}\s*`)
var str = `-cot(x) + c`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}