import re
regex = re.compile(r"[-]{1}[1]{0,1}\s*cot\s*[\(]*\s*x\s*[\)]*\s*\+\s*[a-z]{1}\s*", flags=re.MULTILINE)
test_str = "-cot(x) + c"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")