import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^WM\\/((?>[0-9A-F]{1,4}\\.)*[0-9A-F]{1,4})\\/((?>[0-9A-F]{1,4}\\.)*[0-9A-F]{1,4})$";
final String string = "WM/1F0.E89D/5.D00F.BA7C";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}