$re = '/^WM\/((?>[0-9A-F]{1,4}\.)*[0-9A-F]{1,4})\/((?>[0-9A-F]{1,4}\.)*[0-9A-F]{1,4})$/';
$str = 'WM/1F0.E89D/5.D00F.BA7C';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);