use strict;
my $str = 'WM/1F0.E89D/5.D00F.BA7C';
my $regex = qr/^WM\/((?>[0-9A-F]{1,4}\.)*[0-9A-F]{1,4})\/((?>[0-9A-F]{1,4}\.)*[0-9A-F]{1,4})$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}