#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([2-9]\d|[1-2]\d{2})(?:[.,]\d{1,2})?)$|^300$|^300.0$|^300.00$"
Local $sString = "15.45" & @CRLF & _
"20" & @CRLF & _
"300" & @CRLF & _
"301" & @CRLF & _
"19" & @CRLF & _
"30.495" & @CRLF & _
"49.33" & @CRLF & _
"0" & @CRLF & _
"300.0" & @CRLF & _
"300.01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")