import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([2-9]\\d|[1-2]\\d{2})(?:[.,]\\d{1,2})?)$|^300$|^300.0$|^300.00$";
final String string = "15.45\n"
+ "20\n"
+ "300\n"
+ "301\n"
+ "19\n"
+ "30.495\n"
+ "49.33\n"
+ "0\n"
+ "300.0\n"
+ "300.01";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}