using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([2-9]\d|[1-2]\d{2})(?:[.,]\d{1,2})?)$|^300$|^300.0$|^300.00$";
string input = @"15.45
20
300
301
19
30.495
49.33
0
300.0
300.01";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}