$re = '/^(([2-9]\d|[1-2]\d{2})(?:[.,]\d{1,2})?)$|^300$|^300.0$|^300.00$/m';
$str = '15.45
20
300
301
19
30.495
49.33
0
300.0
300.01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);