const regex = /^(([2-9]\d|[1-2]\d{2})(?:[.,]\d{1,2})?)$|^300$|^300.0$|^300.00$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([2-9]\\d|[1-2]\\d{2})(?:[.,]\\d{1,2})?)$|^300$|^300.0$|^300.00$', 'gm')
const str = `15.45
20
300
301
19
30.495
49.33
0
300.0
300.01`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}