import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\s]+(?=\\s+\\w{7}\\s)";
final String string = "remotes/origin/main 47cdfee add GetLimits function to HelperFunction.ps1 (needed for Labranges)\n"
+ "remotes/origin/splitdvp 9499341 $cleanstring scriptblock removes all nonword chars that survive replace";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}