const regex = /^[^\s]+(?=\s+\w{7}\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\s]+(?=\\s+\\w{7}\\s)', 'gm')
const str = `remotes/origin/main 47cdfee add GetLimits function to HelperFunction.ps1 (needed for Labranges)
remotes/origin/splitdvp 9499341 \$cleanstring scriptblock removes all nonword chars that survive replace`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}