import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(GET|POST)\\s(http|https)://(www.)?(\\w+(\\.|-)?)+/(\\w+(\\.)?)+/((\\w|-)+(\\.)?)+/(\\w+(/)?){4}";
final String string = "GET http://dpservers-pre.alipay.com/odps/service.odps.aliyun-inc.com/api/projects/alipaytech_dev/instances/AQE_409d5e440042b0fa3ff8eb54ddb9dad2?instanceprogress=SQL&taskname=SQL&curr_project=alipaytech_dev";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}