$re = '`(GET|POST)\s(http|https)://(www.)?(\w+(\.|-)?)+/(\w+(\.)?)+/((\w|-)+(\.)?)+/(\w+(/)?){4}`m';
$str = 'GET http://dpservers-pre.alipay.com/odps/service.odps.aliyun-inc.com/api/projects/alipaytech_dev/instances/AQE_409d5e440042b0fa3ff8eb54ddb9dad2?instanceprogress=SQL&taskname=SQL&curr_project=alipaytech_dev';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);