// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(GET|POST)\s(http|https)://(www.)?(\w+(\.|-)?)+/(\w+(\.)?)+/((\w|-)+(\.)?)+/(\w+(/)?){4}").unwrap();
let string = "GET http://dpservers-pre.alipay.com/odps/service.odps.aliyun-inc.com/api/projects/alipaytech_dev/instances/AQE_409d5e440042b0fa3ff8eb54ddb9dad2?instanceprogress=SQL&taskname=SQL&curr_project=alipaytech_dev";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}