# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(GET|POST)\s(http|https)://(www.)?(\w+(\.|-)?)+/(\w+(\.)?)+/((\w|-)+(\.)?)+/(\w+(/)?){4}"
test_str = "GET http://dpservers-pre.alipay.com/odps/service.odps.aliyun-inc.com/api/projects/alipaytech_dev/instances/AQE_409d5e440042b0fa3ff8eb54ddb9dad2?instanceprogress=SQL&taskname=SQL&curr_project=alipaytech_dev"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.