# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<![a-zA-Z])[8&#%9](?=[a-zA-Z])([^\s]*?)(?<=[a-zA-Z])[8&#%9](?![a-zA-Z])/$1/gm;t' <<< "8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs"