const regex = /(?<![a-zA-Z])[8&#%9](?=[a-zA-Z])([^\s]*?)(?<=[a-zA-Z])[8&#%9](?![a-zA-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![a-zA-Z])[8&#%9](?=[a-zA-Z])([^\\s]*?)(?<=[a-zA-Z])[8&#%9](?![a-zA-Z])', 'gm')
const str = `8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);