import re
regex = re.compile(r"(?<![a-zA-Z])[8&#%9](?=[a-zA-Z])([^\s]*?)(?<=[a-zA-Z])[8&#%9](?![a-zA-Z])", flags=re.MULTILINE)
test_str = "8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)