re = /(?<![a-zA-Z])[8&#%9](?=[a-zA-Z])([^\s]*?)(?<=[a-zA-Z])[8&#%9](?![a-zA-Z])/m
str = '8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result