import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![a-zA-Z])[8&#%9](?=[a-zA-Z])([^\\s]*?)(?<=[a-zA-Z])[8&#%9](?![a-zA-Z])";
final String string = "8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}