# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)([89&#%])(\S+)\1(?=\s|$)/$2/gm;t' <<< "8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs"