$re = '/(?<!\S)([89&#%])(\S+)\1(?=\s|$)/m';
$str = '8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;