#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\S)([89&#%])(\S+)\1(?=\s|$)"
Local $sString = "8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)