const regex = /(?<!\S)([89&#%])(\S+)\1(?=\s|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)([89&#%])(\\S+)\\1(?=\\s|$)', 'gm')
const str = `8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);