import Foundation
let pattern = ##"(?<!\S)([89&#%])(\S+)\1(?=\s|$)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"8This8 is &reallly& a #test# of %repl%acing% %mul%tiple 9matched9 9pairs"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)