import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Профессиональная ГИС \\\"Панорама\\\" \\(версия 12(\\.\\d+){2,}, для платформы \\\"x(32|64)\\\"\\)";
final String string = "Профессиональная ГИС \"Панорама\" (версия 12.4.0, для платформы \"x64\")\n"
+ "Профессиональная ГИС \"Панорама\" (версия 12.4.0, для платформы \"x32\")";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}