import re
regex = re.compile(r"Профессиональная ГИС \"Панорама\" \(версия 12(\.\d+){2,}, для платформы \"x(32|64)\"\)")
test_str = ("Профессиональная ГИС \"Панорама\" (версия 12.4.0, для платформы \"x64\")\n"
"Профессиональная ГИС \"Панорама\" (версия 12.4.0, для платформы \"x32\")")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")