// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"Профессиональная ГИС \"Панорама\" \(версия 12(\.\d+){2,}, для платформы \"x(32|64)\"\)"#).unwrap();
let string = "Профессиональная ГИС \"Панорама\" (версия 12.4.0, для платформы \"x64\")
Профессиональная ГИС \"Панорама\" (версия 12.4.0, для платформы \"x32\")";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}