re = /Профессиональная ГИС \"Панорама\" \(версия 12(\.\d+){2,}, для платформы \"x(32|64)\"\)/
str = 'Профессиональная ГИС "Панорама" (версия 12.4.0, для платформы "x64")
Профессиональная ГИС "Панорама" (версия 12.4.0, для платформы "x32")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end