#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"https?://" & @CRLF & _
"(?:" & @CRLF & _
" (?!tbm=(?:isch|news)) # first neg. lookahead" & @CRLF & _
" (?!param1=432) # second" & @CRLF & _
" \S" & @CRLF & _
")+" & @CRLF & _
"$"
Local $sString = "https://www.google.com/search?q=test&tbm=isch&randomParameters=123" & @CRLF & _
"http://www.google.com/thisworks" & @CRLF & _
"https://google.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")